[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

ACPI - APM .. weird things



HI! I sent an email few days ago about ACPI and APM problems on my compaq 
presario 1800.

I update the system,from 5.1-RELEASE to 5.2-RC2, downalod the sys with cvsup, 
recompile ONLY the kernel to :
>uname -a
FreeBSD 127.0.0.1 5.2-CURRENT FreeBSD 5.2-CURRENT #0: Wed Dec 31 15:04:17 GMT 
2003     root_(_at_)_127_(_dot_)_0_(_dot_)_0_(_dot_)_1:/usr/obj/usr/src/sys/MYKERNEL  i386
(MYKERNEL is the GENERIC with device pcm, because adding snd_ess_load="YES" on 
loader.conf wasn't actually creating /dev/dsp.. but this is a different 
story :p)

with 5.1-RELEASE, 5.2 RC2 and now 5.2 CURRENT, the problem is still the same, 
the ACPI doesn't show the life time of the battery. with the 5.2 CURRENT I 
have tried to enable the apm:
>loader.conf:
add apm_load="YES"  #added

>device.hints :
hint.acpi.0.disabled=1 #added
hint.apm.0.disabled=0 #modified

>rc.conf
apm_enabled="YES" #added
apmd_enabled="YES" #added

after the reboot, nothing didn't change, the apm was only saying that I had a 
battery and the total charge of it, but still nothing about the time, so I 
decide to put back the acpi, so I remmed out in device.hints the lines that I 
added, and delete the line on loader.conf, forgottin to delete the lines in 
the rc.conf

after the reboot I saw the line in the dmesg that said that apm wasn't 
compiled with the kernel, I remmed out that lines, but before reboot I 
checked the battery status writing APM

>apm
APM version: 1.2
APM Management: Disabled
AC Line status: off-line
Battery status: high
Remaining battery life: 83%
Remaining battery time:  2:56:00
Number of batteries: 1
Battery 0:
        Battery status: high
        Remaining battery life: 83%
        Remaining battery time:  2:56:00
Resume timer: unknown
[...]

I can see the battery time... I start KDE and also KDE was working fine with 
it, reading the life and the time of the battery....

I rebooted with the lines in the rc.conf remmed out, I still get error on the 
boot from the ACPI (I'll copy the dmesg), but I still can see the life and 
time of the battery, except for KDE, that says that apm is not running...

AND.. when I "put to sleep" the computer, the monitor doesn't go off, except 
if I close the lid. when I try to "wake up" the computer, sometime I get some 
errors after:
ata0: resetting devices ..
but everything works fine.

I don't get the errors if I am in X (KDE)

last thing:

when I was running 5.1-RELEASE the acpi was putting down the use of the CPU in 
battery mode from 8 to 4, with 5.2 the cpu works always at 8:

>sysctl -a hw.acpi (with acline =1)
hw.acpi.supported_sleep_state: S1 S5
hw.acpi.power_button_state: S5
hw.acpi.sleep_button_state: S1
hw.acpi.lid_switch_state: S1
hw.acpi.standby_state: S1
hw.acpi.suspend_state: S3
hw.acpi.sleep_delay: 5
hw.acpi.s4bios: 1
hw.acpi.verbose: 0
hw.acpi.disable_on_poweroff: 1
hw.acpi.reset_video: 1
hw.acpi.cpu.throttle_max: 8
hw.acpi.cpu.throttle_state: 8
hw.acpi.cpu.cx_supported: C1/0 C2/10
hw.acpi.cpu.cx_lowest: 0
hw.acpi.cpu.cx_history: 767689/0 0/0
hw.acpi.thermal.min_runtime: 0
hw.acpi.thermal.polling_rate: 30
hw.acpi.thermal.tz0.temperature: 3252
hw.acpi.thermal.tz0.active: -1
hw.acpi.thermal.tz0.thermal_flags: 0
hw.acpi.thermal.tz0._PSV: 3632
hw.acpi.thermal.tz0._HOT: -1
hw.acpi.thermal.tz0._CRT: 3732
hw.acpi.thermal.tz0._ACx: -1 -1 -1 -1 -1 -1 -1 -1 -1 -1
hw.acpi.battery.life: 88
hw.acpi.battery.time: -1
hw.acpi.battery.state: 2
hw.acpi.battery.units: 1
hw.acpi.battery.info_expire: 5
hw.acpi.acline: 1

>sysctl -a ha.acpi (with the battery only)
hw.acpi.supported_sleep_state: S1 S5
hw.acpi.power_button_state: S5
hw.acpi.sleep_button_state: S1
hw.acpi.lid_switch_state: S1
hw.acpi.standby_state: S1
hw.acpi.suspend_state: S3
hw.acpi.sleep_delay: 5
hw.acpi.s4bios: 1
hw.acpi.verbose: 0
hw.acpi.disable_on_poweroff: 1
hw.acpi.reset_video: 1
hw.acpi.cpu.throttle_max: 8
hw.acpi.cpu.throttle_state: 8
hw.acpi.cpu.cx_supported: C1/0 C2/10
hw.acpi.cpu.cx_lowest: 0
hw.acpi.cpu.cx_history: 772436/0 0/0
hw.acpi.thermal.min_runtime: 0
hw.acpi.thermal.polling_rate: 30
hw.acpi.thermal.tz0.temperature: 3252
hw.acpi.thermal.tz0.active: -1
hw.acpi.thermal.tz0.thermal_flags: 0
hw.acpi.thermal.tz0._PSV: 3632
hw.acpi.thermal.tz0._HOT: -1
hw.acpi.thermal.tz0._CRT: 3732
hw.acpi.thermal.tz0._ACx: -1 -1 -1 -1 -1 -1 -1 -1 -1 -1
hw.acpi.battery.life: 88
hw.acpi.battery.time: 576
hw.acpi.battery.state: 1
hw.acpi.battery.units: 1
hw.acpi.battery.info_expire: 5
hw.acpi.acline: 0


>dmesg
Copyright (c) 1992-2003 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
        The Regents of the University of California. All rights reserved.
FreeBSD 5.2-CURRENT #0: Wed Dec 31 15:04:17 GMT 2003
    root_(_at_)_127_(_dot_)_0_(_dot_)_0_(_dot_)_1:/usr/obj/usr/src/sys/MYKERNEL
Preloaded elf kernel "/boot/kernel/kernel" at 0xc0af4000.
Preloaded elf module "/boot/kernel/acpi.ko" at 0xc0af41f4.
Timecounter "i8254" frequency 1193182 Hz quality 0
CPU: Intel Pentium III (796.54-MHz 686-class CPU)
  Origin = "GenuineIntel"  Id = 0x686  Stepping = 6
  Features=0x387f9ff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,PN,MMX,FXSR,SSE>
real memory  = 134152192 (127 MB)
avail memory = 121618432 (115 MB)
Pentium Pro MTRR support enabled
npx0: [FAST]
npx0: <math processor> on motherboard
npx0: INT 16 interface
acpi0: <PTLTD    RSDT  > on motherboard
pcibios: BIOS version 2.10
Using $PIR table, 9 entries at 0xc00fdf30
    ACPI-1287: *** Error: Method execution failed [\\_SB_.BATT._STA] (Node 
0xc1f52d00), AE_NOT_EXIST
    ACPI-0175: *** Error: Method execution failed [\\_SB_.BATT._STA] (Node 
0xc1f52d00), AE_NOT_EXIST
acpi0: Power Button (fixed)
Timecounter "ACPI-safe" frequency 3579545 Hz quality 1000
    ACPI-1287: *** Error: Method execution failed [\\_SB_.BATT._STA] (Node 
0xc1f52d00), AE_NOT_EXIST
    ACPI-0175: *** Error: Method execution failed [\\_SB_.BATT._STA] (Node 
0xc1f52d00), AE_NOT_EXIST
acpi_timer0: <24-bit timer at 3.579545MHz> port 0x8008-0x800b on acpi0
acpi_cpu0: <CPU> port 0x530-0x537 on acpi0
acpi_tz0: <Thermal Zone> port 0x530-0x537 on acpi0
acpi_button0: <Sleep Button> on acpi0
acpi_button1: <Power Button> on acpi0
pcib0: <ACPI Host-PCI bridge> port 0xcf8-0xcff on acpi0
pci0: <ACPI PCI bus> on pcib0
pcib0: slot 7 INTD is routed to irq 11
pcib0: slot 9 INTA is routed to irq 3
pcib0: slot 17 INTA is routed to irq 5
pcib0: slot 18 INTA is routed to irq 11
agp0: <Intel 82443BX (440 BX) host to PCI bridge> mem 0xf4000000-0xf7ffffff at 
device 0.0 on pci0
pcib1: <ACPI PCI-PCI bridge> at device 1.0 on pci0
pci1: <ACPI PCI bus> on pcib1
pcib1: slot 0 INTA is routed to irq 5
pci1: <display, VGA> at device 0.0 (no driver attached)
isab0: <PCI-ISA bridge> at device 7.0 on pci0
isa0: <ISA bus> on isab0
atapci0: <Intel PIIX4 UDMA33 controller> port 0x14a0-0x14af at device 7.1 on 
pci0
ata0: at 0x1f0 irq 14 on atapci0
ata0: [MPSAFE]
ata1: at 0x170 irq 15 on atapci0
ata1: [MPSAFE]
uhci0: <Intel 82371AB/EB (PIIX4) USB controller> port 0x1480-0x149f irq 11 at 
device 7.2 on pci0
usb0: <Intel 82371AB/EB (PIIX4) USB controller> on uhci0
usb0: USB revision 1.0
uhub0: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub0: 2 ports with 2 removable, self powered
pci0: <bridge, PCI-unknown> at device 7.3 (no driver attached)
pci0: <simple comms> at device 9.0 (no driver attached)
cbb0: <TI1410 PCI-CardBus Bridge> at device 10.0 on pci0
cardbus0: <CardBus bus> on cbb0
pccard0: <16-bit PCCard bus> on cbb0
pcib0: slot 10 INTA is routed to irq 11
cbb0: [MPSAFE]
pcm0: <ESS Solo-1 (unknown vendor)> port 
0x14d8-0x14db,0x14dc-0x14df,0x14b0-0x14bf,0x14c0-0x14cf,0x1400-0x143f irq 5 
at device 17.0 on pci0
fxp0: <Intel 82559 Pro/100 Ethernet> port 0x1440-0x147f mem 
0xf0000000-0xf00fffff,0xf0100000-0xf0100fff irq 11 at device 18.0 on pci0
fxp0: Ethernet address 00:02:a5:14:aa:7a
miibus0: <MII bus> on fxp0
inphy0: <i82555 10/100 media interface> on miibus0
inphy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
    ACPI-1287: *** Error: Method execution failed [\\_SB_.BATT._STA] (Node 
0xc1f52d00), AE_NOT_EXIST
    ACPI-0175: *** Error: Method execution failed [\\_SB_.BATT._STA] (Node 
0xc1f52d00), AE_NOT_EXIST
    ACPI-1287: *** Error: Method execution failed [\\_SB_.BATT._STA] (Node 
0xc1f52d00), AE_NOT_EXIST
    ACPI-0175: *** Error: Method execution failed [\\_SB_.BATT._STA] (Node 
0xc1f52d00), AE_NOT_EXIST
    ACPI-1287: *** Error: Method execution failed [\\_SB_.BATT._STA] (Node 
0xc1f52d00), AE_NOT_EXIST
    ACPI-0175: *** Error: Method execution failed [\\_SB_.BATT._STA] (Node 
0xc1f52d00), AE_NOT_EXIST
    ACPI-1287: *** Error: Method execution failed [\\_SB_.BATT._STA] (Node 
0xc1f52d00), AE_NOT_EXIST
    ACPI-0175: *** Error: Method execution failed [\\_SB_.BATT._STA] (Node 
0xc1f52d00), AE_NOT_EXIST
    ACPI-1287: *** Error: Method execution failed [\\_SB_.BATT._STA] (Node 
0xc1f52d00), AE_NOT_EXIST
    ACPI-0175: *** Error: Method execution failed [\\_SB_.BATT._STA] (Node 
0xc1f52d00), AE_NOT_EXIST
    ACPI-1287: *** Error: Method execution failed [\\_SB_.BATT._STA] (Node 
0xc1f52d00), AE_NOT_EXIST
    ACPI-0175: *** Error: Method execution failed [\\_SB_.BATT._STA] (Node 
0xc1f52d00), AE_NOT_EXIST
    ACPI-1287: *** Error: Method execution failed [\\_SB_.BATT._STA] (Node 
0xc1f52d00), AE_NOT_EXIST
    ACPI-0175: *** Error: Method execution failed [\\_SB_.BATT._STA] (Node 
0xc1f52d00), AE_NOT_EXIST
    ACPI-1287: *** Error: Method execution failed [\\_SB_.BATT._STA] (Node 
0xc1f52d00), AE_NOT_EXIST
    ACPI-0175: *** Error: Method execution failed [\\_SB_.BATT._STA] (Node 
0xc1f52d00), AE_NOT_EXIST
    ACPI-1287: *** Error: Method execution failed [\\_SB_.BATT._STA] (Node 
0xc1f52d00), AE_NOT_EXIST
    ACPI-0175: *** Error: Method execution failed [\\_SB_.BATT._STA] (Node 
0xc1f52d00), AE_NOT_EXIST
    ACPI-1287: *** Error: Method execution failed [\\_SB_.BATT._STA] (Node 
0xc1f52d00), AE_NOT_EXIST
    ACPI-0175: *** Error: Method execution failed [\\_SB_.BATT._STA] (Node 
0xc1f52d00), AE_NOT_EXIST
    ACPI-1287: *** Error: Method execution failed [\\_SB_.BATT._STA] (Node 
0xc1f52d00), AE_NOT_EXIST
    ACPI-0175: *** Error: Method execution failed [\\_SB_.BATT._STA] (Node 
0xc1f52d00), AE_NOT_EXIST
    ACPI-1287: *** Error: Method execution failed [\\_SB_.BATT._STA] (Node 
0xc1f52d00), AE_NOT_EXIST
    ACPI-0175: *** Error: Method execution failed [\\_SB_.BATT._STA] (Node 
0xc1f52d00), AE_NOT_EXIST
    ACPI-1287: *** Error: Method execution failed [\\_SB_.BATT._STA] (Node 
0xc1f52d00), AE_NOT_EXIST
    ACPI-0175: *** Error: Method execution failed [\\_SB_.BATT._STA] (Node 
0xc1f52d00), AE_NOT_EXIST
    ACPI-1287: *** Error: Method execution failed [\\_SB_.BATT._STA] (Node 
0xc1f52d00), AE_NOT_EXIST
    ACPI-0175: *** Error: Method execution failed [\\_SB_.BATT._STA] (Node 
0xc1f52d00), AE_NOT_EXIST
    ACPI-1287: *** Error: Method execution failed [\\_SB_.BATT._STA] (Node 
0xc1f52d00), AE_NOT_EXIST
    ACPI-0175: *** Error: Method execution failed [\\_SB_.BATT._STA] (Node 
0xc1f52d00), AE_NOT_EXIST
    ACPI-1287: *** Error: Method execution failed [\\_SB_.BATT._STA] (Node 
0xc1f52d00), AE_NOT_EXIST
    ACPI-0175: *** Error: Method execution failed [\\_SB_.BATT._STA] (Node 
0xc1f52d00), AE_NOT_EXIST
    ACPI-1287: *** Error: Method execution failed [\\_SB_.BATT._STA] (Node 
0xc1f52d00), AE_NOT_EXIST
    ACPI-0175: *** Error: Method execution failed [\\_SB_.BATT._STA] (Node 
0xc1f52d00), AE_NOT_EXIST
    ACPI-1287: *** Error: Method execution failed [\\_SB_.BATT._STA] (Node 
0xc1f52d00), AE_NOT_EXIST
    ACPI-0175: *** Error: Method execution failed [\\_SB_.BATT._STA] (Node 
0xc1f52d00), AE_NOT_EXIST
    ACPI-1287: *** Error: Method execution failed [\\_SB_.BATT._STA] (Node 
0xc1f52d00), AE_NOT_EXIST
    ACPI-0175: *** Error: Method execution failed [\\_SB_.BATT._STA] (Node 
0xc1f52d00), AE_NOT_EXIST
    ACPI-1287: *** Error: Method execution failed [\\_SB_.BATT._STA] (Node 
0xc1f52d00), AE_NOT_EXIST
    ACPI-0175: *** Error: Method execution failed [\\_SB_.BATT._STA] (Node 
0xc1f52d00), AE_NOT_EXIST
    ACPI-1287: *** Error: Method execution failed [\\_SB_.BATT._STA] (Node 
0xc1f52d00), AE_NOT_EXIST
    ACPI-0175: *** Error: Method execution failed [\\_SB_.BATT._STA] (Node 
0xc1f52d00), AE_NOT_EXIST
    ACPI-1287: *** Error: Method execution failed [\\_SB_.BATT._STA] (Node 
0xc1f52d00), AE_NOT_EXIST
    ACPI-0175: *** Error: Method execution failed [\\_SB_.BATT._STA] (Node 
0xc1f52d00), AE_NOT_EXIST
    ACPI-1287: *** Error: Method execution failed [\\_SB_.BATT._STA] (Node 
0xc1f52d00), AE_NOT_EXIST
    ACPI-0175: *** Error: Method execution failed [\\_SB_.BATT._STA] (Node 
0xc1f52d00), AE_NOT_EXIST
    ACPI-1287: *** Error: Method execution failed [\\_SB_.BATT._STA] (Node 
0xc1f52d00), AE_NOT_EXIST
    ACPI-0175: *** Error: Method execution failed [\\_SB_.BATT._STA] (Node 
0xc1f52d00), AE_NOT_EXIST
    ACPI-1287: *** Error: Method execution failed [\\_SB_.BATT._STA] (Node 
0xc1f52d00), AE_NOT_EXIST
    ACPI-0175: *** Error: Method execution failed [\\_SB_.BATT._STA] (Node 
0xc1f52d00), AE_NOT_EXIST
acpi_cmbat0: <Control Method Battery> on acpi0
acpi_acad0: <AC Adapter> on acpi0
acpi_lid0: <Control Method Lid Switch> on acpi0
atkbdc0: <Keyboard controller (i8042)> port 0x64,0x60 irq 1 on acpi0
atkbd0: <AT Keyboard> flags 0x1 irq 1 on atkbdc0
kbd0 at atkbd0
psm0: <PS/2 Mouse> irq 12 on atkbdc0
psm0: model IntelliMouse, device ID 3
acpi_ec0: <Embedded Controller: GPE 0x9, GLK> port 0x66,0x62 on acpi0
fdc0: cannot reserve control I/O port range (control port)
fdc0: cannot reserve control I/O port range (control port)
orm0: <Option ROM> at iomem 0xc0000-0xcefff on isa0
pmtimer0 on isa0
fdc0: <Enhanced floppy controller (i82077, NE72065 or clone)> at port 
0x3f7,0x3f0-0x3f5 irq 6 drq 2 on isa0
fdc0: FIFO enabled, 8 bytes threshold
fd0: <1440-KB 3.5" drive> on fdc0 drive 0
ppc0: <Parallel port> at port 0x378-0x37f irq 7 on isa0
ppc0: SMC-like chipset (ECP/EPP/PS2/NIBBLE) in COMPATIBLE mode
ppc0: FIFO with 16/16/15 bytes threshold
ppbus0: <Parallel port bus> on ppc0
plip0: <PLIP network interface> on ppbus0
lpt0: <Printer> on ppbus0
lpt0: Interrupt-driven port
ppi0: <Parallel I/O> on ppbus0
sc0: <System console> at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=0x300>
sio0 at port 0x3f8-0x3ff irq 4 flags 0x10 on isa0
sio0: type 16550A
sio1: configured irq 3 not in bitmap of probed irqs 0
sio1: port may not be enabled
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
Timecounter "TSC" frequency 796541496 Hz quality 800
Timecounters tick every 10.000 msec
acpi_cpu: throttling enabled, 8 steps (100% to 12.5%), currently 100.0%
system power profile changed to 'economy'
system power profile changed to 'performance'
GEOM: create disk ad0 dp=0xc201d560
ad0: 19077MB <HITACHI_DK23BA-20> [38760/16/63] at ata0-master UDMA33
acd0: DVDROM <TOSHIBA DVD-ROM SD-C2502> at ata1-master PIO4


sorry for my english, Italian guy here.
Thanks a lot

Fabrizio Parrella