[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

prism 2.5 timeout in wi_cmd 0x010b



Hi,

This is the context:

 - Stable as of Jan 9 (FreeBSD 4.9-STABLE #14: Fri Jan  9 15:04:16 PST 2004)
   The problem was present since Dec 22.. at least.

 - Linksys PCI WMP11/Prism:

wi0: <Intersil Prism2.5> mem 0xf8a02000-0xf8a02fff irq 5 at device 11.0 on pci2
wi0: 802.11 address: 00:06:25:09:a7:8f
wi0: using RF:PRISM2.5 MAC:ISL3874A(Mini-PCI)
wi0: Intersil Firmware: Primary 1.01.00, Station 1.04.02

 acting as a client. The AP is a DLink 614+ (I've tried various
 versions of the firmware).

 - High volume of transmitted traffic (ftp-ed a few MBs within the
   WLAN). Either towards the AP or towards other clients (E.g. AN350).

And this is the symptom:

wi0: timeout in wi_cmd 0x010b; event status 0x0000
wi0: xmit failed

after this the NIC is dead.
Sometimes the box freezes for a few seconds, sometimes it doesn't.
Most of the times the NIC doesn't resume unless it brought up/down
(ifconfig down/up).

More messages (after the NIC stops working):

wi0: watchdog timeout
wi0: timeout in wi_cmd 0x0002; event status 0x0000
wi0: wi_cmd: busy bit won't clear.
wi0: wi_cmd: busy bit won't clear.
wi0: wi_cmd: busy bit won't clear.
wi0: init failed
wi0: watchdog timeout

Complete log attached. I'm able to reproduce this consistently ;(
I can do some debugging and provide more info, if needed.

	thanks,
	Lorenzo
 
-------------- next part --------------
Copyright (c) 1992-2003 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
	The Regents of the University of California. All rights reserved.
FreeBSD 4.9-STABLE #14: Fri Jan  9 15:04:16 PST 2004
    lorenzo_(_at_)_HP:/usr/src/sys/compile/HPi
Timecounter "i8254"  frequency 1193182 Hz
CPU: Intel(R) Pentium(R) 4 CPU 2.40GHz (2392.04-MHz 686-class CPU)
  Origin = "GenuineIntel"  Id = 0xf27  Stepping = 7
  Features=0xbfebfbff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CLFLUSH,DTS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE>
real memory  = 536870912 (524288K bytes)
avail memory = 516653056 (504544K bytes)
Preloaded elf kernel "kernel" at 0xc0591000.
Preloaded elf module "linux.ko" at 0xc059109c.
Preloaded elf module "snd_ich.ko" at 0xc059113c.
Preloaded elf module "snd_pcm.ko" at 0xc05911dc.
Preloaded elf module "bktr_mem.ko" at 0xc059127c.
Preloaded elf module "bktr.ko" at 0xc059131c.
Warning: Pentium 4 CPU: PSE disabled
bktr_mem: memory holder loaded
Pentium Pro MTRR support enabled
md0: Malloc disk
Using $PIR table, 9 entries at 0xc00ebfd0
apm0: <APM BIOS> on motherboard
apm0: found APM BIOS v1.2, connected at v1.2
npx0: <math processor> on motherboard
npx0: INT 16 interface
pcib0: <Intel 82845 Host to PCI bridge> on motherboard
pci0: <PCI bus> on pcib0
agp0: <Intel 82845 host to AGP bridge> mem 0xec000000-0xefffffff at device 0.0 on pci0
pcib1: <Intel 82845 PCI-PCI (AGP) bridge> at device 1.0 on pci0
pci1: <PCI bus> on pcib1
pci1: <ATI model 5159 graphics accelerator> at 0.0 irq 10
pcib2: <Intel 82801BA/BAM (ICH2) Hub to PCI bridge> at device 30.0 on pci0
pci2: <PCI bus> on pcib2
atapci0: <Promise TX2 ATA133 controller> port 0x1040-0x104f,0x1064-0x1067,0x1058-0x105f,0x1060-0x1063,0x1050-0x1057 mem 0xf8500000-0xf8503fff irq 5 at device 4.0 on pci2
ata2: at 0x1050 on atapci0
ata3: at 0x1058 on atapci0
fxp0: <Intel 82801BA/CAM (ICH2/3) Pro/100 Ethernet> port 0x1000-0x103f mem 0xf8504000-0xf8504fff irq 5 at device 8.0 on pci2
fxp0: Ethernet address 00:0b:cd:3d:97:f4
inphy0: <i82562EM 10/100 media interface> on miibus0
inphy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
bktr0: <BrookTree 878> mem 0xf8a00000-0xf8a00fff irq 11 at device 10.0 on pci2
bktr0: Hauppauge Model 61311 A MB
bktr0: Detected a MSP3430G-A1 at 0x80
bktr0: Hauppauge WinCast/TV, Philips NTSC tuner, msp3400c stereo.
pci2: <unknown card> (vendor=0x109e, dev=0x0878) at 10.1 irq 11
wi0: <Intersil Prism2.5> mem 0xf8a02000-0xf8a02fff irq 5 at device 11.0 on pci2
wi0: 802.11 address: 00:06:25:09:a7:8f
wi0: using RF:PRISM2.5 MAC:ISL3874A(Mini-PCI)
wi0: Intersil Firmware: Primary 1.01.00, Station 1.04.02
isab0: <Intel 82801BA/BAM (ICH2) PCI to LPC bridge> at device 31.0 on pci0
isa0: <ISA bus> on isab0
atapci1: <Intel ICH2 ATA100 controller> port 0x3480-0x348f at device 31.1 on pci0
ata0: at 0x1f0 irq 14 on atapci1
ata1: at 0x170 irq 15 on atapci1
uhci0: <Intel 82801BA/BAM (ICH2) USB controller USB-A> port 0x3440-0x345f irq 11 at device 31.2 on pci0
usb0: <Intel 82801BA/BAM (ICH2) USB controller USB-A> on uhci0
usb0: USB revision 1.0
uhub0: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub0: 2 ports with 2 removable, self powered
umass0: SMSC ww, rev 2.00/1.95, addr 2
ums0: vendor 0x062a product 0x0000, rev 1.10/2.04, addr 3, iclass 3/1
ums0: 5 buttons and Z dir.
uhci1: <Intel 82801BA/BAM (ICH2) USB controller USB-B> port 0x3460-0x347f irq 10 at device 31.4 on pci0
usb1: <Intel 82801BA/BAM (ICH2) USB controller USB-B> on uhci1
usb1: USB revision 1.0
uhub1: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub1: 2 ports with 2 removable, self powered
pcm0: <Intel ICH2 (82801BA)> port 0x3400-0x343f,0x3000-0x30ff irq 11 at device 31.5 on pci0
pcm0: <Analog Devices AD1885 AC97 Codec>
orm0: <Option ROMs> at iomem 0xc0000-0xccfff,0xcd000-0xce7ff,0xce800-0xd0fff on isa0
pmtimer0 on isa0
fdc0: <NEC 72065B or clone> at port 0x3f0-0x3f5,0x3f7 irq 6 drq 2 on isa0
fdc0: FIFO enabled, 8 bytes threshold
fd0: <1440-KB 3.5" drive> on fdc0 drive 0
atkbdc0: <Keyboard controller (i8042)> at port 0x60,0x64 on isa0
atkbd0: <AT Keyboard> flags 0x1 irq 1 on atkbdc0
kbd0 at atkbd0
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
sc0: <System console> at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=0x300>
sio0 at port 0x3f8-0x3ff irq 4 flags 0x10 on isa0
sio0: type 16550A
sio1 at port 0x2f8-0x2ff irq 3 on isa0
sio1: type 16550A
ppc0: <Parallel port> at port 0x378-0x37f irq 7 on isa0
ppc0: SMC-like chipset (ECP/EPP/PS2/NIBBLE) in COMPATIBLE mode
ppc0: FIFO with 16/16/13 bytes threshold
ppbus0: IEEE1284 device found /NIBBLE
Probing for PnP devices on ppbus0:
ppbus0: <Hewlett-Packard HP LaserJet 6L/0101.01> PRINTER HP ENHANCED PCL5,PJL
plip0: <PLIP network interface> on ppbus0
lpt0: <Printer> on ppbus0
lpt0: Interrupt-driven port
ppi0: <Parallel I/O> on ppbus0
IP packet filtering initialized, divert enabled, rule-based forwarding enabled, default to accept, logging disabled
ad0: 38166MB <Maxtor 6E040L0> [77545/16/63] at ata0-master UDMA100
ad4: 194481MB <Maxtor 6Y200P0> [395136/16/63] at ata2-master UDMA133
acd0: DVD-ROM <HL-DT-STDVD-ROM GDR8161B> at ata1-slave PIO4
pcm0: measured ac97 link rate at 55922 Hz
Mounting root from ufs:/dev/ad0s2a
da0 at umass-sim0 bus 0 target 0 lun 0
da0: <SMSC ww    HS-CF 1.95> Removable Direct Access SCSI-0 device 
da0: 650KB/s transfers
da0: Attempt to query device size failed: NOT READY, Medium not present
wi0: timeout in wi_cmd 0x010b; event status 0x0000
wi0: xmit failed
wi0: watchdog timeout
wi0: timeout in wi_cmd 0x0002; event status 0x0000
wi0: wi_cmd: busy bit won't clear.
wi0: wi_cmd: busy bit won't clear.
wi0: wi_cmd: busy bit won't clear.
wi0: init failed
wi0: watchdog timeout
wi0: timeout in wi_cmd 0x010b; event status 0x0000
wi0: xmit failed
wi0: watchdog timeout
wi0: timeout in wi_cmd 0x0002; event status 0x0000
wi0: wi_cmd: busy bit won't clear.
wi0: wi_cmd: busy bit won't clear.
wi0: wi_cmd: busy bit won't clear.
wi0: init failed
wi0: timeout in wi_seek to fc07/0; last status 810b
wi0: timeout in wi_seek to fc00/0; last status 810b
wi0: wi_cmd: busy bit won't clear.
wi0: wi_cmd: busy bit won't clear.
wi0: wi_cmd: busy bit won't clear.
wi0: wi_cmd: busy bit won't clear.
wi0: wi_cmd: busy bit won't clear.
wi0: wi_cmd: busy bit won't clear.
wi0: wi_cmd: busy bit won't clear.
wi0: wi_cmd: busy bit won't clear.
wi0: wi_cmd: busy bit won't clear.
wi0: wi_cmd: busy bit won't clear.
wi0: wi_cmd: busy bit won't clear.
wi0: wi_cmd: busy bit won't clear.
wi0: wi_cmd: busy bit won't clear.
wi0: wi_cmd: busy bit won't clear.
wi0: wi_cmd: busy bit won't clear.
wi0: wi_cmd: busy bit won't clear.
wi0: wi_cmd: busy bit won't clear.
wi0: wi_cmd: busy bit won't clear.
wi0: wi_cmd: busy bit won't clear.
wi0: wi_cmd: busy bit won't clear.
wi0: wi_cmd: busy bit won't clear.
wi0: failed to allocate 1594 bytes on NIC
wi0: tx buffer allocation failed
wi0: wi_cmd: busy bit won't clear.
wi0: failed to allocate 1594 bytes on NIC
wi0: mgmt. buffer allocation failed
wi0: timeout in wi_seek to 0/0; last status 4000
wi0: timeout in wi_seek to 0/44; last status 4044
wi0: watchdog timeout

Visit your host, monkey.org