[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

prism 2.5 timeout in wi_cmd 0x010b



same result: the patch doesn't fix the problem.

However after upgrding the Prism firmware (1.1.0 -> 1.1.1)
the lock up stopped.

Still I cannot get more that 2.5Mb/s Tx from the Prism (as a client)
to another client (Aironet). A little better (3 / 3.5) from the Prism
to the AP (DI 614+).

"wi" is reporting a lot of TX collision, but "an" isn't when I change
the direction of the traffic. In this case I get better rate.. but
still not optimal as "wi" get conficts on the ACKs.

Another anomaly shows up when running dhclient: often the system
freezes/slows down for a few fractions of a second (BTW: I've noticed
this with the Aironet driver as well). Also acquiring a lease
has become more unreliable..

	Lorenzo

On Sun, Jan 11, 2004 at 02:29:46AM +0100, Marko Zec wrote:
> On Sunday 11 January 2004 01:34, Kevin Oberman wrote:
> >
> > Marko,
> >
> > I just started re-building my kernel with this patch. I have
> > previously reported this under CURRENT and hope that this might fix
> > the problem. It has also been reported by several others under
> > slightly different circumstances. I'll report what I see. It's pretty
> > easy to test...just copy a multi-megabyte file from my laptop to my
> > workstation over the wireless.
> >
> 
> Whoops... it seems that my hack doesn't fix the problem of outgoing 
> traffic hosing the wi interface - next time I'll do more testing before 
> making a post. However, without this patch my wi would lock up every 
> now and than out of the blue, regardless whether it was associated to 
> an AP or it was disconnected, and regardless whether there was any 
> traffic flowing through it or not. The same card (Prism 2.5 mini-PCI) 
> used to play nicely with 4.8-R, and works quite well with M$ also. 
> There must be something rotten in the recent wi driver...
> 
> Cheers,
> 
> Marko