[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

5.2-release sound issues, -current hangs



hello,

I just got an Asus notebook, model M3000N and installed 5.2.
Sound wouldn't work and after tinkering with it for awhile, I attempted
to upgrade to -current. At this point, current wouldn't boot and hung at 
GEOM: Unable to create ad0

dmesg is displaying some sound error that I recall seeing in a few older
versions of FreeBSD:

pcm0: <Intel ICH4 (82801DB)> port 0xe100-0xe13f,0xe000-0xe0ff at device
31.5 on pci0
pcm0: unable to map IO port space
device_probe_and_attach: pcm0 attach returned 6

Attached is the full dmesg output.

Any suggestions are welcome ;)

cheers,
-matt

-- 
Matt Olander
(408)943-4100 Phone
(408)943-4101 Fax
www.offmyserver.com
--
"Those who don't read have no advantage over those who can't"
-Mark Twain
-------------- next part --------------
Copyright (c) 1992-2004 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
	The Regents of the University of California. All rights reserved.
FreeBSD 5.2-RELEASE #2: Wed Jan 14 10:54:16 PST 2004
    matto_(_at_)_laptop_(_dot_)_nat_(_dot_)_ixsystems_(_dot_)_net:/usr/src/sys/i386/compile/lapkern
Preloaded elf kernel "/boot/kernel.old/kernel" at 0xc0aa4000.
Preloaded elf module "/boot/kernel.old/acpi.ko" at 0xc0aa41d0.
Timecounter "i8254" frequency 1193182 Hz quality 0
CPU: Intel(R) Pentium(R) M processor 1400MHz (1400.05-MHz 686-class CPU)
  Origin = "GenuineIntel"  Id = 0x695  Stepping = 5
  Features=0xa7e9fbbf<FPU,VME,DE,PSE,TSC,MSR,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,CLFLUSH,DTS,ACPI,MMX,FXSR,SSE,SSE2,TM,PBE>
real memory  = 527695872 (503 MB)
avail memory = 502915072 (479 MB)
Pentium Pro MTRR support enabled
npx0: [FAST]
npx0: <math processor> on motherboard
npx0: INT 16 interface
acpi0: <A M I  OEMRSDT > on motherboard
acpi0: Power Button (fixed)
Timecounter "ACPI-fast" frequency 3579545 Hz quality 1000
acpi_timer0: <24-bit timer at 3.579545MHz> port 0xe408-0xe40b on acpi0
acpi_cpu0: <CPU> port 0x530-0x537 on acpi0
acpi_tz0: <Thermal Zone> port 0x530-0x537 on acpi0
pcib0: <ACPI Host-PCI bridge> port 0xcf8-0xcff on acpi0
pci0: <ACPI PCI bus> on pcib0
pcib0: slot 2 INTA is routed to irq 11
pcib0: slot 29 INTA is routed to irq 11
pcib0: slot 29 INTB is routed to irq 5
pcib0: slot 29 INTC is routed to irq 4
pcib0: slot 29 INTD is routed to irq 4
pci0: <base peripheral> at device 0.1 (no driver attached)
pci0: <base peripheral> at device 0.3 (no driver attached)
agp0: <Intel 8285xM (85xGM GMCH) SVGA controller> port 0xdc00-0xdc07 mem 0xffa80000-0xffafffff,0xf0000000-0xf7ffffff irq 11 at device 2.0 on pci0
agp0: detected 8060k stolen memory
agp0: aperture size is 128M
pci0: <display> at device 2.1 (no driver attached)
uhci0: <Intel 82801DB (ICH4) USB controller USB-A> port 0xd480-0xd49f irq 11 at device 29.0 on pci0
usb0: <Intel 82801DB (ICH4) USB controller USB-A> on uhci0
usb0: USB revision 1.0
uhub0: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub0: 2 ports with 2 removable, self powered
uhci1: <Intel 82801DB (ICH4) USB controller USB-B> port 0xd800-0xd81f irq 5 at device 29.1 on pci0
usb1: <Intel 82801DB (ICH4) USB controller USB-B> on uhci1
usb1: USB revision 1.0
uhub1: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub1: 2 ports with 2 removable, self powered
uhci2: <Intel 82801DB (ICH4) USB controller USB-C> port 0xd880-0xd89f irq 4 at device 29.2 on pci0
usb2: <Intel 82801DB (ICH4) USB controller USB-C> on uhci2
usb2: USB revision 1.0
uhub2: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub2: 2 ports with 2 removable, self powered
pci0: <serial bus, USB> at device 29.7 (no driver attached)
pcib1: <ACPI PCI-PCI bridge> at device 30.0 on pci0
pci1: <ACPI PCI bus> on pcib1
pcib1: slot 5 INTB is routed to irq 11
pcib1: slot 8 INTA is routed to irq 11
cbb0: <RF5C475 PCI-CardBus Bridge> at device 5.0 on pci1
cardbus0: <CardBus bus> on cbb0
pccard0: <16-bit PCCard bus> on cbb0
pcib1: slot 5 INTA is routed to irq 5
cbb0: [MPSAFE]
fwohci0: <Ricoh R5C551> mem 0xff7fe800-0xff7fefff irq 11 at device 5.1 on pci1
fwohci0: OHCI version 1.0 (ROM=1)
fwohci0: No. of Isochronous channel is 4.
fwohci0: EUI64 00:e0:18:00:03:14:76:4a
fwohci0: Phy 1394a available S400, 2 ports.
fwohci0: Link S400, max_rec 2048 bytes.
firewire0: <IEEE1394(FireWire) bus> on fwohci0
fwe0: <Ethernet over FireWire> on firewire0
if_fwe0: Fake Ethernet address: 02:e0:18:14:76:4a
sbp0: <SBP-2/SCSI over FireWire> on firewire0
fwohci0: Initiate bus reset
fwohci0: BUS reset
fwohci0: node_id=0xc800ffc0, gen=1, CYCLEMASTER mode
firewire0: 1 nodes, maxhop <= 0, cable IRM = 0 (me)
firewire0: bus manager 0 (me)
fxp0: <Intel 82801DB (ICH4) Pro/100 VM Ethernet> port 0xcc00-0xcc3f mem 0xff7ff000-0xff7fffff irq 11 at device 8.0 on pci1
fxp0: Ethernet address 00:0e:a6:13:b6:2d
miibus0: <MII bus> on fxp0
inphy0: <i82562EM 10/100 media interface> on miibus0
inphy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
isab0: <PCI-ISA bridge> at device 31.0 on pci0
isa0: <ISA bus> on isab0
atapci0: <Intel ICH4 UDMA100 controller> port 0xffa0-0xffaf,0-0x3,0-0x7,0-0x3,0-0x7 at device 31.1 on pci0
ata0: at 0x1f0 irq 14 on atapci0
ata0: [MPSAFE]
ata1: at 0x170 irq 15 on atapci0
ata1: [MPSAFE]
pcm0: <Intel ICH4 (82801DB)> port 0xe100-0xe13f,0xe000-0xe0ff at device 31.5 on pci0
pcm0: unable to map IO port space
device_probe_and_attach: pcm0 attach returned 6
pci0: <simple comms> at device 31.6 (no driver attached)
acpi_button0: <Sleep Button> on acpi0
acpi_lid0: <Control Method Lid Switch> on acpi0
acpi_acad0: <AC Adapter> on acpi0
acpi_cmbat0: <Control Method Battery> on acpi0
acpi_cmbat1: <Control Method Battery> on acpi0
atkbdc0: <Keyboard controller (i8042)> port 0x64,0x60 irq 1 on acpi0
atkbd0: <AT Keyboard> flags 0x1 irq 1 on atkbdc0
kbd0 at atkbd0
psm0: <PS/2 Mouse> irq 12 on atkbdc0
psm0: model Generic PS/2 mouse, device ID 0
acpi_ec0: <Embedded Controller: GPE 0x1c> port 0x66,0x62 on acpi0
sio0: configured irq 3 not in bitmap of probed irqs 0
sio0: port may not be enabled
sio0 port 0x2f8-0x2ff irq 3 drq 1 on acpi0
sio0: type 16550A
ppc0 port 0x778-0x77f,0x378-0x37f irq 7 drq 3 on acpi0
ppc0: SMC-like chipset (ECP/EPP/PS2/NIBBLE) in COMPATIBLE mode
ppc0: FIFO with 16/16/8 bytes threshold
ppbus0: <Parallel port bus> on ppc0
plip0: <PLIP network interface> on ppbus0
lpt0: <Printer> on ppbus0
lpt0: Interrupt-driven port
ppi0: <Parallel I/O> on ppbus0
orm0: <Option ROM> at iomem 0xc0000-0xccfff on isa0
pmtimer0 on isa0
fdc0: ready for input in output
fdc0: cmd 3 failed at out byte 1 of 3
sc0: <System console> at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=0x300>
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
Timecounter "TSC" frequency 1400053678 Hz quality 800
Timecounters tick every 10.000 msec
acpi_cpu: throttling enabled, 8 steps (100% to 12.5%), currently 100.0%
GEOM: create disk ad0 dp=0xc493f760
ad0: 38154MB <IC25N040ATMR04-0> [77520/16/63] at ata0-master UDMA100
acd0: CDRW <UJDA750 DVD/CDRW> at ata1-master PIO4
GEOM: create disk cd0 dp=0xc475e600
cd0 at ata1 bus 0 target 0 lun 0
cd0: <MATSHITA UJDA750 DVD/CDRW 1.50> Removable CD-ROM SCSI-0 device 
cd0: 16.000MB/s transfers
cd0: Attempt to query device size failed: NOT READY, Medium not present - tray closed
Mounting root from ufs:/dev/ad0s1a

Visit your host, monkey.org