[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Compaq Evo N800v: DSDT from F18F Firmware (latest)



Hi everyone.

As mentioned in the topic i'm using a Compaq Evo N800v with the latest 
Firmware from www.compaq.de (i think it's also avaiable from compaq.com).

Version F18F is avaiable since October 2003.

My computer is equipped with a Pentium 4m 1.6GHz, 512MB RAM and a 30GB 
harddisk from Fujitsu (please tell me if you need to more detailed 
information).

I'm currently running FreeBSD 5.2-Release on it (partially with a 
current kernel to see if things have improved but most time i run a 
Release World and Kernel which i also use for testing).

Most hardware related things are doing fine so far.

But as you can see from the topic i still got several problems with ACPI.

Mainly i can't see my battery status.

In order to get this i dissasembled my DSDT with acpidump -d and 
debugged it (please take a look a the attachment for compile errors):
I've
-added External() wherever there was Error 1022 (Object missing),
-deleted the "*" in alphanumerical expressions,
-replaced "Return (0x00)" with "Noop" (at least in the places where it 
gave me 2 warnings)

The first error returned me the following:

compaq_dsdt_orig    13:                 Return (C003)
Error    1022 -              Object does not exist ^  (C003)

I solved this by taking Firmware Ver. F18A from acpi.sourceforge.net and 
copied Name (C003, Package (0x03) { ... }) to F18F by copy and paste.

Surprisingly that worked for me :)

I've attached the original F18F and my patched that gave me finally 0 
Errors and 0 Warnings when compiling it.

Having done this not to much has changed:
Fans work as they did before but there is still no battery status 
information.

It might interesting to know that when i insert the battery while the 
computer is up and running it gets recognized by FreeBSD (doesn't depend 
on DSDT) but never when i am booting from battery.

So i tried to boot with the F18A DSDT from Sourceforge.
With this DSDT i get my battery state but my fans and the temperature 
control won't work anymore (i know you're just laughing at that moment, 
aren't you? :) )

As i am too unexperienced to debug the F18F DSDT further on i kindly ask 
you for help.

Maybe someone has done this before or has got enough skills to make F18F 
work with fans and battery status.

As far as i have come up to now there are Device (BAT0) and Device 
(BAT1) entries in F18A. I've found similar entries in F18F from line 
4039 on (in my patched DSDT). They are called "Device (C132)" and 
"Device (C133)". But i haven't got an idea what might be wrong with that.

In the attachment you'll find my dmesg giving a whole bunch of errors 
with the F18A and a second one with F18F.

I've also attached the compiling errors with the original F18F DSDT.

Furtheron you'll find three DSDT's: F18A from acpi.sf.net, the original 
F18F (by acpidump -d) and my patched F18F.

I hope you find this information useful and have some ideas or even a 
solution for me.

Regards

Jochen Keil

P.S.: Please forgive mistakes in spelling and grammar as i am not a 
native english speaker.