[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

probably simple ethernet problem...



Probably something really simple, but although my internal 802.11 card works 
fine I can't get the internal 3Com 3c905C-TX ethernet card to accept an 
address, either from ifconfig or dhclient.  I'm sure it actually works 
because when I built FreeBSD 5.1R on this machine I used it to connect via 
NFS to another machine with the iso disk since the firewire driver can't map 
memory for my external cd (different unresolved problem).  Anyway, after 
getting 5.1R up I configured wi0 and forgot about xl0 until I went on a 
trip.  Even though ifconfig seems to show the card as being recognized and 
active (when plugged in) dhclient "hangs" and I never get an address.

Any suggestions?
Doug Carter
FreeBSD,  week 4.

*From /etc/rc.conf:

# -- sysinstall generated deltas -- # Tue Jan  6 01:31:15 2004
# Created: Tue Jan  6 01:31:15 2004
# Enable network daemons for user convenience.
# Please make all changes to this file, not to /etc/defaults/rc.conf.
# This file now contains just the overrides from /etc/defaults/rc.conf.
network_interfaces="lo0 xl0 wi0"
ifconfig_xl0="DHCP"
hostname="x200.private.net"
devd_enable=YES
kern_securelevel_enable="NO"
inetd_enable="YES"
linux_enable="YES"
moused_enable="YES"
rpcbind_enable="YES"
mountd_flags="-r"
nfs_client_enable="YES"
nfs_server_enable="YES"
sendmail_enable="YES"
sshd_enable="YES"
usbd_enable="YES"
lpd_enable="YES"
pccard_mem="YES"
pccard_beep="2"


*From /etc/start_if.wi0:

ifconfig wi0 channel 5
ifconfig wi0 ssid WAP1
ifconfig wi0 stationname x200
ifconfig wi0 wep
ifconfig wi0 wepkey "0x...deleted...."
dhclient wi0


*From /var/log/dmesg.today:


xl0: <3Com 3c905C-TX Fast Etherlink XL> port 0xa000-0xa07f mem 
0xe0200800-0xe020087f irq 11 at device 5.0 on pci2
xl0: Ethernet address: 00:06:5b:89:0f:76
miibus0: <MII bus> on xl0
ukphy0: <Generic IEEE 802.3u media interface> on miibus0
ukphy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
cbb1: <TI1410 PCI-CardBus Bridge> at device 7.0 on pci2
cardbus1: <CardBus bus> on cbb1
pccard1: <16-bit PCCard bus> on cbb1
pcib1: slot 7 INTA is routed to irq 10
isab0: <PCI-ISA bridge> at device 31.0 on pci0
isa0: <ISA bus> on isab0


*From ifconfig:

xl0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 1500
    options=3<RXCSUM,TXCSUM>
    inet6 fe80::206:5bff:fe89:f76%xl0 prefixlen 64 scopeid 0x1
    inet 0.0.0.0 netmask 0xff000000 broadcast 255.255.255.255
    ether 00:06:5b:89:0f:76
    media: Ethernet autoselect (none)
    status: no carrier
lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> mtu 16384
    inet6 ::1 prefixlen 128
    inet6 fe80::1%lo0 prefixlen 64 scopeid 0x2
    inet 127.0.0.1 netmask 0xff000000
wi0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 1500
    inet6 fe80::202:2dff:fe56:fb01%wi0 prefixlen 64 scopeid 0x3
    inet 192.168.1.102 netmask 0xffffff00 broadcast 192.168.1.255
    ether 00:02:2d:56:fb:01
    media: IEEE 802.11 Wireless Ethernet autoselect (DS/11Mbps)
    status: associated
    ssid WAP1 1:WAP1
    stationname x200
    channel 5 authmode OPEN powersavemode OFF powersavesleep 100
    wepmode MIXED weptxkey 1
    wepkey 1:128-bit

_________________________________________________________________
Rethink your business approach for the new year with the helpful tips here. 
http://special.msn.com/bcentral/prep04.armx