[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

5.2-release NDIS panic (Dell D800 Broadcom TruMobile 1400)



On Jan 23, "Amar Takhar" wrote:

> On 2004-01-22 19:17 -0800, Mike Hunter wrote:
> > Hey everybody,
> > 
> > I was trying to get the NDIS driver working on my laptop.  I followed
> > instructions I found here:
> > 
> > http://www.freebsd.org/cgi/getmsg.cgi?fetch=20768+26271+/usr/local/www/db/text/2003/freebsd-mobile/20031221.freebsd-mobile
> 
> A few things here, that method is no longer required and has been obsoleted.

Has a new set of instructions been posted? :)

> Bill has hooked the ndisulator into ifconfig.
> 
> So, as a start, please make _sure_ you have the latest ndis sources.

I cvsup'd with tag "." from cvsup.freebsd.org...sorry for my ignorance,
but how else can I check?

#cd /usr/src/sys/compat/ndis/
# ls -l
total 228
-rw-r--r--  1 root  wheel   2050 Dec 17 19:51 cfg_var.h
-rw-r--r--  1 root  wheel   2170 Jan 15 13:31 hal_var.h
-rw-r--r--  1 root  wheel  33072 Jan 21 11:14 kern_ndis.c
-rw-r--r--  1 root  wheel  45067 Jan 21 13:09 ndis_var.h
-rw-r--r--  1 root  wheel   5252 Jan 19 12:45 ntoskrnl_var.h
-rw-r--r--  1 root  wheel  14336 Jan 15 13:31 pe_var.h
-rw-r--r--  1 root  wheel   4845 Dec 11 14:34 resource_var.h
-rw-r--r--  1 root  wheel   7524 Jan 15 11:34 subr_hal.c
-rw-r--r--  1 root  wheel  66360 Jan 18 14:57 subr_ndis.c
-rw-r--r--  1 root  wheel  23137 Jan 19 11:57 subr_ntoskrnl.c
-rw-r--r--  1 root  wheel  15702 Jan 13 14:49 subr_pe.c

> Also one thing seems odd to me:
> 
> > ndis0: 11b rates: 1Mbps 2Mbps 5.5Mbps 11Mbps
> 
> 
> You should be getting rates reported as:
> 
> Jan 21 22:09:14 peach kernel: bcm0: 11b rates: 1Mbps 2Mbps 5.5Mbps 11Mbps
> Jan 21 22:09:14 peach kernel: bcm0: 11g rates: 6Mbps 9Mbps 12Mbps 18Mbps 36Mbps 48Mbps 54Mbps

I agree :|

> Also, an IRQ of ii dosn't seem quite right :)

:\

> Double check that you have used the CORRECT drive from Dell's site, you want the
> XP drivers which are in the _parent_ directory after you have unzipped the EXE.

I'm pretty sure I'm using the right driver file, R63259.EXE.  The dell
site says it's for the truemobile 1400....

When you say parent directory, you mean TMSetup/, as opposed to its
subdirectories, right?

> After this, if it _still_ dosn't work, repond to the list and i'll walk you
> through some debugging procedures.

Thanks for all the help.

> Also, what model is this laptop?

It's a dell latitude D800.

Mike

Visit your host, monkey.org