[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

USB2 on laptop..



I have a laptop with FreeBSD 5.2/i386 on which I want to connect a DVD-Burner.
The available ports are 2xUSB1, 100Mbps ether, and Pcmcia/Cardbus. Which in
practice points out the cardbus slot as the useful choice. As 1x DVD-R is the
same as 8x CD-R which is 150 kB/s which rules out USB1, and there are no
ethernet<->IDE adaptors (that I found).

Connecting the DVD burner via IDE<->USB2 adapter should work. Now the only
missing piece is the USB2 port which is gained through a cardbus usb2 card.
Any tip on how to get usb2 via cardbus working?

I can successfully connect a pcmcia ethernet card:
  ed1: <CNet CN40BC Ethernet> at port 0x100-0x11f irq 10 function 0 config 32 on pccard0
  ed1: address 00:80:ad:a9:2b:ac, type NE2000 (16 bit) 


But two USB2 cardbus cards fail:
  NEC uPD 9210 USB
    cardbus0: Resource not specified in CIS: id=10, size=1000
    ohci0: <NEC uPD 9210 USB controller> mem 0x80101000-0x80101fff irq 10 at device 0.0 on cardbus0
    usb2: OHCI version 1.0
    usb2: <NEC uPD 9210 USB controller> on ohci0
    usb2: USB revision 1.0
    uhub2: NEC OHCI root hub, class 9/0, rev 1.00/1.00, addr 1
    uhub2: 3 ports with 3 removable, self powered
    
    cardbus0: Resource not specified in CIS: id=10, size=1000
    ohci1: <NEC uPD 9210 USB controller> mem 0x80102000-0x80102fff irq 10 at device 0.1 on cardbus0
    usb3: OHCI version 1.0
    usb3: <NEC uPD 9210 USB controller> on ohci1
    usb3: USB revision 1.0
    uhub3: NEC OHCI root hub, class 9/0, rev 1.00/1.00, addr 1
    uhub3: 2 ports with 2 removable, self powered
    
    cardbus0: Resource not specified in CIS: id=10, size=100
    cardbus0: <serial bus, USB> at device 0.2 (no driver attached)
    
    --Card removed--   
    cardbus0: release_all_resource: Resource still owned by child, oops. (type=1, rid=0, addr=a)
    cardbus0: release_all_resource: Resource still owned by child, oops. (type=3, rid=16, addr=80101000)
    cardbus0: release_all_resource: Resource still owned by child, oops. (type=1, rid=0, addr=a)
    cardbus0: release_all_resource: Resource still owned by child, oops. (type=3, rid=16, addr=80102000)


  Belkin useing NEC uPD 9210:
    cardbus0: Resource not specified in CIS: id=10, size=1000
    ohci0: <NEC uPD 9210 USB controller> mem 0x80101000-0x80101fff irq 10 at device 0.0 on cardbus0
    usb2: OHCI version 1.0
    usb2: <NEC uPD 9210 USB controller> on ohci0
    usb2: USB revision 1.0
    uhub2: NEC OHCI root hub, class 9/0, rev 1.00/1.00, addr 1
    uhub2: 1 port with 1 removable, self powered
    cardbus0: Resource not specified in CIS: id=10, size=1000
    cardbus0: <unknown> at device 0.1 (no driver attached)
    cardbus0: Resource not specified in CIS: id=10, size=100
    cardbus0: <serial bus, USB> at device 0.2 (no driver attached)
    
    cardbus0: release_all_resource: Resource still owned by child, oops. (type=1, rid=0, addr=a)
    cardbus0: release_all_resource: Resource still owned by child, oops. (type=3, rid=16, addr=80101000)

    --Card removed--   
    CBB EVENT 0xe
    Waking up thread
    Status is 0x30000827
    cardbus0: release_all_resource: Resource still owned by child, oops. (type=1, rid=0, addr=a)
    cardbus0: release_all_resource: Resource still owned by child, oops. (type=3, rid=16, addr=80101000)
    cardbus0: release_all_resource: Resource still owned by child, oops. (type=1, rid=0, addr=a)
    cardbus0: release_all_resource: Resource still owned by child, oops. (type=3, rid=16, addr=80102000)
    CBB EVENT 0x6
    
    CBB EVENT 0x6
    Waking up thread
    Status is 0x30000821
    cbb0: card inserted: event=0x00000000, state=30000821
    cbb0: cbb_power: 3V
    cardbus0: Resource not specified in CIS: id=10, size=1000
    cardbus0: Non-prefetchable memory at 80101000-80101fff
    ohci0: <NEC uPD 9210 USB controller> mem 0x80101000-0x80101fff irq 10 at device 0.0 on cardbus0
    usb2: OHCI version 1.0
    usb2: <NEC uPD 9210 USB controller> on ohci0
    usb2: USB revision 1.0
    uhub2: NEC OHCI root hub, class 9/0, rev 1.00/1.00, addr 1
    uhub2: 1 port with 1 removable, self powered
    cardbus0: Resource not specified in CIS: id=10, size=1000
    cardbus0: Non-prefetchable memory at 80102000-80102fff
    ohci1: <NEC uPD 9210 USB controller> mem 0x80102000-0x80102fff irq 10 at device 0.1 on cardbus0
    usb3: OHCI version 1.0
    usb3: <NEC uPD 9210 USB controller> on ohci1
    usb3: USB revision 1.0
    uhub3: NEC OHCI root hub, class 9/0, rev 1.00/1.00, addr 1
    uhub3: 1 port with 1 removable, self powered
    cardbus0: Resource not specified in CIS: id=10, size=100
    cardbus0: Non-prefetchable memory at 80103000-801030ff
    cardbus0: <serial bus, USB> at device 0.2 (no driver attached)
    
    --Enforced by modifying /usr/src/sys/dev/cardbus/cardbus_cis.c--
    ohci0: <NEC uPD 9210 USB controller> at device 0.0 on cardbus0
    ohci0: Could not map memory
    device_probe_and_attach: ohci0 attach returned 6
    ohci0: <NEC uPD 9210 USB controller> at device 0.1 on cardbus0
    ohci0: Could not map memory
    device_probe_and_attach: ohci0 attach returned 6
    cardbus0: <serial bus, USB> at device 0.2 (no driver attached)
    cbb0: CardBus card activation failed

I even tried a firewire card without success:
  cardbus0: Expecting link target, got 0x0
  cardbus0: Resource not specified in CIS: id=10, size=800
  cardbus0: Resource not specified in CIS: id=14, size=4000
  cardbus0: Resource not specified in CIS: id=18, size=800
  fwohci0: <Texas Instruments TSB12LV23> mem 0x80108000-0x801087ff,0x80104000-0x80107fff,0x80108800-0x80108fff irq 10 at device 0.0 on cardbus0
  fwohci0: OHCI version ff.ff (ROM=1)
  fwohci0: invalid OHCI version
  fwohci0: FireWire init failed
  device_probe_and_attach: fwohci0 attach returned 5
  cbb0: CardBus card activation failed

The dmesg:
  Copyright (c) 1992-2004 The FreeBSD Project.
  Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
  	The Regents of the University of California. All rights reserved.
  FreeBSD 5.2-RELEASE #0: Sun Jan 11 04:21:45 GMT 2004
      root_(_at_)_wv1u_(_dot_)_btc_(_dot_)_adaptec_(_dot_)_com:/usr/obj/usr/src/sys/GENERIC
  Preloaded elf kernel "/boot/kernel/kernel" at 0xc0a33000.
  Preloaded elf module "/boot/kernel/acpi.ko" at 0xc0a3321c.
  Timecounter "i8254" frequency 1193182 Hz quality 0
  CPU: Intel(R) Celeron(TM) CPU                1133MHz (1133.21-MHz 686-class CPU)
    Origin = "GenuineIntel"  Id = 0x6b1  Stepping = 1
    Features=0x383f9ff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,MMX,FXSR,SSE>
  real memory  = 125698048 (119 MB)
  avail memory = 112467968 (107 MB)
  Pentium Pro MTRR support enabled
  npx0: [FAST]
  npx0: <math processor> on motherboard
  npx0: INT 16 interface
  acpi0: <Acer   FALCON3M> on motherboard
  pcibios: BIOS version 2.10
  Using $PIR table, 5 entries at 0xc00fb700
  acpi0: Power Button (fixed)
  Timecounter "ACPI-fast" frequency 3579545 Hz quality 1000
  acpi_timer0: <24-bit timer at 3.579545MHz> port 0xf108-0xf10b on acpi0
  acpi_cpu0: <CPU> on acpi0
  acpi_tz0: <Thermal Zone> on acpi0
  acpi_tz1: <Thermal Zone> on acpi0
  acpi_button0: <Sleep Button> on acpi0
  pcib0: <ACPI Host-PCI bridge> port 0xcf8-0xcff on acpi0
  pci0: <ACPI PCI bus> on pcib0
  pcib0: slot 2 INTA is routed to irq 11
  pcib0: slot 29 INTA is routed to irq 11
  pcib0: slot 29 INTB is routed to irq 11
  pcib0: slot 31 INTB is routed to irq 10
  pcib0: slot 31 INTB is routed to irq 10
  pcib0: slot 31 INTB is routed to irq 10
  agp0: <Intel 82830M (830M GMCH) SVGA controller> mem 0x90100000-0x9017ffff,0x98000000-0x9fffffff irq 11 at device 2.0 on pci0
  agp0: detected 8060k stolen memory
  agp0: aperture size is 128M
  pci0: <display> at device 2.1 (no driver attached)
  uhci0: <Intel 82801CA/CAM (ICH3) USB controller USB-A> port 0xbca0-0xbcbf irq 11 at device 29.0 on pci0
  usb0: <Intel 82801CA/CAM (ICH3) USB controller USB-A> on uhci0
  usb0: USB revision 1.0
  uhub0: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
  uhub0: 2 ports with 2 removable, self powered
  uhci1: <Intel 82801CA/CAM (ICH3) USB controller USB-B> port 0xbce0-0xbcff irq 11 at device 29.1 on pci0
  usb1: <Intel 82801CA/CAM (ICH3) USB controller USB-B> on uhci1
  usb1: USB revision 1.0
  uhub1: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
  uhub1: 2 ports with 2 removable, self powered
  pcib1: <ACPI PCI-PCI bridge> at device 30.0 on pci0
  pci1: <ACPI PCI bus> on pcib1
  pcib1: slot 5 INTA is routed to irq 11
  pcib1: slot 9 INTA is routed to irq 10
  rl0: <RealTek 8139 10/100BaseTX> port 0xa000-0xa0ff mem 0xa0100000-0xa01001ff irq 11 at device 5.0 on pci1
  rl0: Ethernet address: 00:00:e2:4a:b9:28
  miibus0: <MII bus> on rl0
  rlphy0: <RealTek internal media interface> on miibus0
  rlphy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
  cbb0: <O2Micro OZ6912/6972 PCI-CardBus Bridge> irq 10 at device 9.0 on pci1
  cardbus0: <CardBus bus> on cbb0
  pccard0: <16-bit PCCard bus> on cbb0
  cbb0: [MPSAFE]
  cbb0: bad Vcc request. ctrl=0x1000f00, status=0x1000f73
  cbb_power: 0V
  isab0: <PCI-ISA bridge> at device 31.0 on pci0
  isa0: <ISA bus> on isab0
  atapci0: <Intel ICH3 UDMA100 controller> port 0xc060-0xc06f,0xc048-0xc04b,0xc030-0xc037,0xc018-0xc01b,0xc000-0xc007 at device 31.1 on pci0
  ata0: at 0x1f0 irq 14 on atapci0
  ata0: [MPSAFE]
  ata1: at 0x170 irq 15 on atapci0
  ata1: [MPSAFE]
  pci0: <serial bus, SMBus> at device 31.3 (no driver attached)
  pci0: <multimedia, audio> at device 31.5 (no driver attached)
  pci0: <simple comms> at device 31.6 (no driver attached)
  acpi_lid0: <Control Method Lid Switch> on acpi0
  acpi_acad0: <AC Adapter> on acpi0
  acpi_cmbat0: <Control Method Battery> on acpi0
  atkbdc0: <Keyboard controller (i8042)> port 0x64,0x60 irq 1 on acpi0
  atkbd0: <AT Keyboard> flags 0x1 irq 1 on atkbdc0
  kbd0 at atkbd0
  fdc0: <Enhanced floppy controller (i82077, NE72065 or clone)> port 0x3f7,0x3f0-0x3f5 irq 6 drq 2 on acpi0
  fdc0: FIFO enabled, 8 bytes threshold
  fd0: <1440-KB 3.5" drive> on fdc0 drive 0
  sio0 port 0x3f8-0x3ff irq 4 on acpi0
  sio0: type 16550A
  psm0: <PS/2 Mouse> irq 12 on atkbdc0
  psm0: model Generic PS/2 mouse, device ID 0
  acpi_ec0: <Embedded Controller: GPE 0x1d> port 0x66,0x62 on acpi0
  orm0: <Option ROM> at iomem 0xc0000-0xcbfff on isa0
  pmtimer0 on isa0
  sc0: <System console> at flags 0x100 on isa0
  sc0: VGA <16 virtual consoles, flags=0x300>
  sio1: configured irq 3 not in bitmap of probed irqs 0
  sio1: port may not be enabled
  vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
  Timecounter "TSC" frequency 1133208793 Hz quality 800
  Timecounters tick every 10.000 msec
  GEOM: create disk ad0 dp=0xc1fca960
  ad0: 19077MB <TOSHIBA MK2018GAP> [38760/16/63] at ata0-master UDMA100
  acd0: CDROM <MATSHITA CR-177> at ata1-master PIO4
  Mounting root from ufs:/dev/ad0s1a
  pcm0: <Intel ICH3 (82801CA)> port 0xb400-0xb43f,0xb000-0xb0ff irq 10 at device 31.5 on pci0
  pcm0: <Cirrus Logic CS4299 AC97 Codec>

Kernel is the one from iso-images disc1.

    /Peter