[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Flashing MA311 to later firmware



Hi,

I've been having problems with my machine locking up when my wife's
windows'98 laptop is using the MA311 hostAP:
	wi0: timeout in wi_seek to 14b/3c; last status 403c
	wi0: timeout in wi_seek to 14b/3c; last status 403c
	wi0: timeout in wi_seek to 14b/3c; last status 403c

Huh-Oh you're thinking that the firmware needs updating, well I've
come to that conclusion myself as it's running 1.0.7/1.3.6
	wi0: Intersil Firmware: Primary 1.00.07, Station 1.03.06

Now, the tricky part: I don't have windows anywhere I can plug this
card into.  I've tried using flash.exe 0.5e from FreeDOS:
A:\FW> flash.exe -vb -d pk010101.hex

But it complains about a blank/invalid PDA area on the card, and
asks if I want to continue. (from the site in the .cz mentioned on
several pages google returned on this topic)

I don't have a copy of what the PDA area should be, so I'm hesitant
to over-ride this warning in case it kills the (mostly) working
card.

If I try and do
A:\FW> flash -vb -s
flash.exe reports an error 'Bad Status 2674 auxEnable failed.'

[I get the same error trying to copy the pda off the card]

I've read the archive, but the only thing I can find is a post from
dougb telling someone to search the archive for a post he made
[then] recently, but the search string in that post doesn't return
anything useful. (and neither does the archive on geocrawler.com]

Anyone got any suggestions, magic incantations for flash.exe that
would allow me to upgrade the firmware. If I were running linux I
guess I could use flash_srec, I couldn't find the equivalent for
FreeBSD.

Thanks in advance... and please reply to the list so someone else
can make use of the result.

/RjL