[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Synaptics touchpad issues



HP omnibook xe4500, 3.5-stable.
I have to disable ohci because it makes kernel freeze on boot. The
touchpad (synaptics on ps/2) works well, except that it is way too
sensitive (unusable) and whenever I push a mouse button, the cursor
moves right or up or both, about an inch. It's pretty hard to hit
buttons ;-) Protocol is wsmouse, and I tried both wsmouse and wsmouse0
as device. Is there any way to filter the mouse input coming from the
tuchpad?

Regards,
Sandor

OpenBSD 3.5 (GENERIC) #34: Mon Mar 29 12:24:55 MST 2004
    deraadt@i386.openbsd.org:/usr/src/sys/arch/i386/compile/GENERIC
cpu0: Intel(R) Pentium(R) 4 Mobile CPU 1.70GHz ("GenuineIntel"
686-class) 1.70 GHz
cpu0:
FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUS
H,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM
real mem  = 803778560 (784940K)
avail mem = 739057664 (721736K)
using 4278 buffers containing 40292352 bytes (39348K) of memory
User Kernel Config
UKC> disable ohci*
111 ohci* disabled
UKC> quit
Continuing...
mainbus0 (root)
bios0 at mainbus0: AT/286+(bd) BIOS, date 10/18/02, BIOS32 rev. 0 @
0xfd750
pcibios0 at bios0: rev. 2.1 @ 0xfd750/0x8b0
pcibios0: PCI IRQ Routing Table rev. 1.0 @ 0xfdf30/176 (9 entries)
pcibios0: PCI Interrupt Router at 000:07:0 ("Acer Labs M1533 ISA" rev
0x00)
pcibios0: PCI bus #3 is the last bus
bios0: ROM list: 0xc0000/0xf000 0xcf000/0x1000 0xe0000/0x4000!
0xe4000/0x1000!
pci0 at mainbus0 bus 0: configuration mode 1 (no bios)
pchb0 at pci0 dev 0 function 0 vendor "Acer Labs", unknown product
0x1671 rev 0x02
ppb0 at pci0 dev 1 function 0 "Acer Labs M5247 AGP/PCI-PCI" rev 0x00
pci1 at ppb0 bus 1
vga1 at pci1 dev 0 function 0 "ATI Radeon Mobility M6 LY" rev 0x00
wsdisplay0 at vga1: console (80x25, vt100 emulation)
wsdisplay0: screen 1-5 added (80x25, vt100 emulation)
"Acer Labs M5237 USB" rev 0x03 at pci0 dev 2 function 0 not configured
autri0 at pci0 dev 6 function 0 "Acer Labs M5451 Audio" rev 0x02: irq 5
ac97: codec id 0x43585429 (Conexant CX20468)
ac97: codec features reserved, headphone, 18 bit DAC, 18 bit ADC, No 3D
Stereo
audio0 at autri0
midi0 at autri0: <4DWAVE MIDI UART>
pcib0 at pci0 dev 7 function 0 "Acer Labs M1533 ISA" rev 0x00
vendor "Acer Labs", unknown product 0x5457 (class communications
subclass modem, rev 0x00) at pci0 dev 8 function 0 not configured
wi0 at pci0 dev 9 function 0 "Intersil PRISM2.5 Mini-PCI WLAN" rev 0x01:
irq 10
wi0: PRISM2.5 ISL3874A(Mini-PCI), Firmware 1.1.0 (primary), 1.4.9
(station), address 00:d0:59:44:53:a3
cbb0 at pci0 dev 10 function 0 "Texas Instruments PCI1520 CardBus" rev
0x01: irq 5
cbb1 at pci0 dev 10 function 1 "Texas Instruments PCI1520 CardBus" rev
0x01: irq 5
"Texas Instruments TSB43AB21 FireWire" rev 0x00 at pci0 dev 12 function
0 not configured
pciide0 at pci0 dev 16 function 0 "Acer Labs M5229 UDMA IDE" rev 0xc4:
DMA, channel 0 wired to compatibility, channel 1 wired to compatibility
wd0 at pciide0 channel 0 drive 0: <TOSHIBA MK3018GAP>
wd0: 16-sector PIO, LBA, 28615MB, 58605120 sectors
wd0(pciide0:0:0): using PIO mode 4, Ultra-DMA mode 5
atapiscsi0 at pciide0 channel 1 drive 0
scsibus0 at atapiscsi0: 2 targets
cd0 at scsibus0 targ 0 lun 0: <QSI, DVD/CDRW SBW-081, NI01> SCSI0
5/cdrom removable
cd0(pciide0:1:0): using PIO mode 4, Ultra-DMA mode 2
"Acer Labs M7101 Power Mgmt" rev 0x00 at pci0 dev 17 function 0 not
configured
sis0 at pci0 dev 18 function 0 "NS DP83815 10/100" rev 0x00: DP83815D,
irq 11, address 00:c0:9f:0a:cf:7f
nsphyter0 at sis0 phy 0: DP83815 10/100 integrated, rev. 1
isa0 at pcib0
isadma0 at isa0
pckbc0 at isa0 port 0x60/5
pckbd0 at pckbc0 (kbd slot)
pckbc0: using irq 1 for kbd slot
wskbd0 at pckbd0: console keyboard, using wsdisplay0
pmsi0 at pckbc0 (aux slot)
pckbc0: using irq 12 for aux slot
wsmouse0 at pmsi0 mux 0
pcppi0 at isa0 port 0x61
midi1 at pcppi0: <PC speaker>
sysbeep0 at pcppi0
lpt0 at isa0 port 0x378/4 irq 7
npx0 at isa0 port 0xf0/16: using exception 16
pccom0 at isa0 port 0x3f8/8 irq 4: ns16550a, 16 byte fifo
pccom1 at isa0 port 0x2f8/8 irq 3: ns16550a, 16 byte fifo
fdc0 at isa0 port 0x3f0/6 irq 6 drq 2
fd0 at fdc0 drive 0: 1.44MB 80 cyl, 2 head, 18 sec
cardslot0 at cbb0 slot 0 flags 0
cardbus0 at cardslot0: bus 2 device 0 cacheline 0x0, lattimer 0x20
pcmcia0 at cardslot0
cardslot1 at cbb1 slot 1 flags 0
cardbus1 at cardslot1: bus 3 device 0 cacheline 0x0, lattimer 0x20
pcmcia1 at cardslot1
biomask c060 netmask cc60 ttymask dce2
pctr: user-level cycle counter enabled
dkcsum: wd0 matched BIOS disk 80
root on wd0a
rootdev=0x0 rrootdev=0x300 rawdev=0x302