[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: trying to upgrade to current from 2.2



In message <19980502195038.AAA6658@kids.webfreaks.com> Mark Castillo writes:
: cd /usr/src/gnu/usr.bin/gas; make; make install

Except on alpha, mips a ppc, where you need to follow the gcc stuff,
but for /usr/src/gnu/usr.bin/binutils.  Since you didn't say what
hardware you were on, I thought I'd mention it (since I hit the same
problems on my arc update).

: cc   -o telnetd authenc.o global.o slc.o state.o sys_term.o telnetd.o
: termstat.o
:  utility.o -lutil -ltermcap -ltelnet -lkrb -ldes
: blah, blah, blah........
...
: utility.o: Undefined symbol `_enctype_names' referenced from text segment^M

I had something similar to this.  It turned out that I had a bogus
libtelnet in my /usr/lib that was shared and for some reason it was
trying to link against that rather than against the .a file.  Rm'ing
that file made this go away.  I'd tell you what file, exactly, it was,
but I already removed it :-)

But my system has been updated many times from pre-2.0 days so tends
to have a lot of cruft in it, so it might be something completely
different.

Warner