[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Having problems installing and booting mac68k



I'm attempting to get OpenBSD 2.2 running on a Macintosh SE/30 with 8
MB of RAM, but am having no luck.  Neither bsd-generic.tar.gz or
bsd-genericsbc.tar.gz will want to install from the install program.
It just dies almost immediatly after opening the file saying there was
an error in the file--incorrect code or something.  However, the file
is not corrupted in any way.

I was able to get around that by decompressing the kernel distribution
and using cpin from the installer to copy bsd to /.  comp22, etc22 and
base22 all installed without a hitch; I created the device files
without any problems.

I then tried to boot up the system using Mac Booter.  Unfortunately,
it dies on `Set _mac68k_vrsrc_cnt'.  The mouse doesn't move, nothing
happens after several minutes of just sitting there.  I've tried both
kernels and every imaginable set of options using Mac Booter to no
avail--it gives me the same message every time and freezes.

I'd really appreciate any help on this matter, or at least an
explanation why OpenBSD isn't booting.