[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: source update broke the build



hasn't Daniel Colpi said ? ...
> 
> Greetings all,
> 
> I am currently compiling a kernal.  This compile worked a few days ago,
> then a change to the source tree was made, which made it break the build.
> I am compiling on a DEC 3100.
> 
> The problem is in many cases you are trying to include mips/*.h where you
> should be (I think) including mips/include/*.h
> 
> I fixed it by:
> biotest# pwd
> /a/bashful.bio/usr/bashful/src/sys/arch/mips
> biotest# ls
> CVS/      README    conf/     dev/      include/  mips/
> biotest# foreach i ( include/*.h )
> ? ln -s $i
> ? end
> biotest# ls
> CVS/            dev/            kbdreg.h@       pcb.h@          reloc.h@
> README          disklabel.h@    kcore.h@        pio.h@          setjmp.h@
> ansi.h@         dlfcn.h@        kdbparam.h@     pmap.h@         signal.h@
> archtype.h@     ecoff.h@        limits.h@       proc.h@         stdarg.h@
> asm.h@          elf_abi.h@      link.h@         profile.h@      trap.h@
> cdefs.h@        float.h@        memconf.h@      ptrace.h@       types.h@
> conf/           frame.h@        mips/           reg.h@          varargs.h@
> cpu.h@          ieeefp.h@       mips_opcode.h@  regdef.h@       vmparam.h@
> db_machdep.h@   include/        param.h@        regnum.h@
> 
> But I am sure there is a better solution by actually changing the source
> to include the correct files.

todd c. miller has changed the pmax port so that it now takes most of
its mips include files from the shared mips directory - thus you'll
have to add mips to your machine line in the config file

...
machine		pmax mips
...

this should fix your problem

t

-- 
  thomas graichen - graichen@rzpd.de graichen@OpenBSD.org graichen@FreeBSD.org

  perfection is reached, not when there is no longer anything to add, but when
      there is no longer anything to take away    antoine de saint-exupery