[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

No Subject





Gretings all,

I am still trying to get OpenBSD on a DEC 5000-240.  To do this I am
getting a GENERIC kernal to compile on a DEC 3100.  I would then like to
walk the disk to the 5000-240 and put OpenBSD on it.

I am following the steps in the FAQ.

I first copy GENERIC to GENERIC_ON_RZ1.

I then add the line:
config                bsd root on rz1a swap on rz1b dumps on rz1b

and comment out the line:
#config         bsd swap generic

then I configure  GENERIC_ON_RZ1

then I cd into the compile directory 

I then have to edit the Makefile to change the line:
CDIAGFLAGS=    -Werror -Wno-main

to:
CDIAGFLAGS=     -Werror

this is because my computer doesn't know what -Wno-main is.

and make depend and make.


When I did this I got an error saying "can't find locore.h in
../../../../arch/pmax so I created a link to the locore.h file in
../../../../arch/pmax/include in the ../../../../arch/pmax directory.

This made it compile and I tried it on my DEC 3100.  It came up in
single and when I tried to go multi, it complained about it not being
able to mount rz1d on /usr and that the device was not configured.

So I brought it up in single again and did a fsck

Same error, Device not configured

Tried to read it using disklable, same error.

tried to mount it manually, same error.

So I brought it back up with my origional kernal (version 2.1) and it
worked fine.  I have gotten a 2.3 kernal to work on this DEC 3100, but
it didn't work on the DEC 5000-240 due to keyboard and mouse problems.

Can someone please tell me how to get Open BSD onto my DEC 5000-240?


Thank you in advance,
Daniel Colpi
Purdue University