[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Got it! (was Dial-in)



On Fri, 29 May 1998, Nick Ellson wrote:

>
>Found the first bug.
>
>I had to add :np: (No Parity) in the std-57600 entry in my /etc/gettytab 
>file. Now I connect and I can see my text great :)
>
>Though I do have an interesting querk. When my system first boots, I can't 
>connect al att.. I run kermit, connect to the modem through /dev/cua01 and 
>type at <return> then exit kermit and I am set. Is there an automated way 
>to say "hi" to my modem like this? ;)

Try setting the speed with an stty line in rc.local?

-- Jay

>Nick
> 
>
>
>> On Fri, 29 May 1998, Nick Ellson wrote:
>> 
>> >I think I am REAL close now to getting dial-in services working for
>> >terminals. My modem (an internal Practical Peripherals 28800) is now set
>> >up to at least answer the phone as tty01. Now when I DO get connected I
>> >get garbage, so maybe something else is just set wrong.
>> 
>> Garbage is a symptom of a speed mismatch between your com port and
>> modem. If, for example, you used cu to configure your modem and the
>> uucp configuration was left at the default 9600, you locked the port
>> at the speed of the first AT command. Getty doesn't know you locked
>> the modem at 9600, so you get garbage. Power your modem off and on for a
>> short term fix -- make sure everything talks to the modem at 57600 for the
>> correct fix.
>> 
>> >My modem string looks right
>> >&C1 - Pay attention to Carrier Detect
>> >&D3 - Monitor DTR, and do a Hang-Up and RESET when it's toggled.
>> >&K3 - Use Hardware RTS/CTS flow control
>> >E0 - Turn Echo Off
>> >Q0 - Turn Off Result Codes
>> >
>> >This was from the requirements list on the FreeBSD handbook, I just
>> >looked up the proper at commands in my modem book. (theirs were for a USR
>> >14.4)
>> 
>> I beg to pick a nit. &S1 should be set if that means DSR active on
>> answer and inactive on carrier loss. It seems to be so on most modems, but
>> check your docs. Save it, and &Y0 to profile 0. &D3 reloads default
>> profile. (Unless you really like noise, M0 might be a good register to
>> set.;)
>> 
>> >- my /etc/ttys reads:
>> >
>> >tty01 "/usr/libexec/getty std.57600" dialup on
>> 
>> I'd prefer: tty01 "/usr/libexec/getty std.57600" unknown on insecure
>> 
>> But otherwise, ok.
>> 
>> >- And my /etc/gettytab has this section for std.57600
>> >
>> >std.57600|57600-baud:\
>> >      :sp#57600:
>> 
>> Also ok.
>> 
>> >(I think this might not be right)
>> 
>> It is.
>> 
>> >These are all the files I am currently messing with to try to get "Login:
>> > " to appear when calling in from Procomm on my desk top. Have I missed
>> >something?
>> 
>> Nothing more than what's mentioned above.
>> 
>> -- Jay
>> 
>
>
>--
>Nick Ellson
>Customer Support
>Imagenation           HTTP://www.imagenation.com