[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

New approach

>From what everyone that has answered me as said at some point, serial
ports are a pain ;) But I think I have a new approach that actually speaks
to my needs without getting into getty.

The following from Ian got me farther than I expected to get anytime
tonight. I blocked out the getty in /etc/ttys and tried making a
/etc/ppp/options.tty01 file like this

9600  (still working on that speed issue ;)
passive (.2 is my server, and I want .3 given to the Win95

                         client so he can be seen on the internal IP net)
login proxyarp require-pap

and a /etc/ppp/pap-secrets file like

nicke newmail "" *

My test user account is nicke who has a password in the passwd file

then I do a 

# pppd /etc/tty01

and pppd sits and waits for my modem. When I dial in with my Win95 station
as nicke it actually works!! However, on the server screen I get 3 lines
that say 

PPPD[some id]: Cannot determine ethernet address for proxy ARP

then it hands out the IP addresses I asked for which check out when I do a
'winipcfg' on my win95 station, so it got an address of like
it should have. But it can't talk on the network. I can't even ping which is my server it connected to. :I

I think this approach is the way I would LIKE to solve because it is my
final goal, to have a single line PPP server to give access to my local

You goys have been very helpful with my getty problems, and I appreciate
that. I appologize if it looks as if I switched gears for now. 

Does anyone have ideas on why pppd can't make proxy ARP happy?

> I haven't tried this as yet, just use pppd to dial out, fell free to
> correct any mistakes. Hope this helps.

Nick Ellson
Customer Support
Imagenation           HTTP://www.imagenation.com