[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Compiler errors...





Many times when I'm compiling a big program, the compiler dies with a
signal 11:

gcc: Internal compiler error: program cc1 got fatal signal 11

When I start to compile again it goes fine until it dies again. It seems
to do it randomly.

I ran into this a long time ago with linux 0.99 or around there on my old
486. It had somthing to do with the memory timin or something? I've tried
playing with the timings, and I have disabled Video and BIOS shadow ram,
and it still does this. I'm using Openbsd 2.3, the dmesg output is
below. (sorry about the length of this message)

Thanks for any help,
josh

OpenBSD 2.3 (GENERIC) #6: Mon Apr 20 06:34:43 MDT 1998
    deraadt@i386:/usr/src/sys/arch/i386/compile/GENERIC
cpu0: Intel Pentium/MMX ("GenuineIntel" 586-class) 188 MHz
cpu0: F00F bug workaround installed
BIOS mem  = 654336 conventional, 99614720 extended
real mem  = 100270080
avail mem = 90370048
using 1249 buffers containing 5115904 bytes of memory
mainbus0 (root)
bios0 at mainbus0: AT/286+(cf) BIOS, date 10/08/97
bios0: pciinfo 0xf042e00c apminfo 0xf042e028 diskinfo 0xf042e050 cksumlen 1 memmap 0xf042e0cc
apm0 at bios0: Power Management spec V1.1
APM power mgmt engage (device 1): power management disabled (1)
apm0: AC on, battery charge [no battery]
pci0 at mainbus0 bus 0: configuration mode 1 (bios)
pchb0 at pci0 dev 0 function 0 "VIA Technologies VT82C595 (Apollo VP2) Host-PCI Bridge" rev 0x06
"VIA Technologies VT82C586 (Apollo VP) PCI-ISA Bridge" rev 0x27 at pci0 dev 7 function 0 not configured
"S3 ViRGE DX/GX" rev 0x01 at pci0 dev 9 function 0 not configured
ep0 at pci0 dev 10 function 0 "3Com 3c905 100Base-TX" rev 0x00: address 00:60:97:96:5e:66, mii default mii irq 11
isa0 at mainbus0
lpt0 at isa0 port 0x378-0x37b irq 7
isadma0 at isa0
wdc0 at isa0 port 0x1f0-0x1f7 irq 14
atapibus0 at wdc0
wd0 at wdc0 drive 0: <WDC AC23200L>
wd0: 3098MB, 6296 cyl, 16 head, 63 sec, 512 bytes/sec (256KB cache)
wd0: using 16-sector 16-bit pio transfers, lba addressing
wdc1 at isa0 port 0x170-0x177 irq 15
atapibus1 at wdc1
acd0 at atapibus1 drive 0: <IDE/ATAPI CD-ROM, M2C5> ATAPI 5/cdrom removable
acd0: 687/2750Kb/sec, 128Kb cache, audio play, 255 volume levels
npx0 at isa0 port 0xf0-0xff: using exception 16
pccom0 at isa0 port 0x3f8-0x3ff irq 4: ns16550a, 16 byte fifo
pccom1 at isa0 port 0x2f8-0x2ff irq 3: ns16550a, 16 byte fifo
vt0 at isa0 port 0x60-0x6f irq 1: unknown S3, 80 col, color, 8 scr, mf2-kbd
pms0 at vt0 irq 12
fdc0 at isa0 port 0x3f0-0x3f7 irq 6 drq 2
fd0 at fdc0 drive 0: 1.44MB 80 cyl, 2 head, 18 sec
isapnp0 at isa0 port 0x279: read port 0x203
isapnp0: <OPTi Audio 16, OPT0007, , IDE CD> port 0x36e/2,0x168/8 irq 10 not configured
isapnp0: <OPTi Audio 16, OPT9310, , OPTi Audio 16> port 0x534/4,0x380/12,0x220/16,0xe0c/4 irq 5 drq 0,0 not configured
isapnp0: <OPTi Audio 16, OPT0001, , Game Port> port 0x200/1 not configured
isapnp0: <OPTi Audio 16, OPT0002, , MPU401> port 0x300/2 irq 5 not configured
biomask c040 netmask c840 ttymask d8c2
root on wd0a
pctr: user-level cycle counter enabled
dkcsum: wd0 matched BIOS disk 80
rootdev=0x0 rrootdev=0x300 rawdev=0x302