[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Compiling GNUstep 1.6 under OpenBSD 3.2



Part of the problem here, is that a variety of change were introduced
into the makefile system to support (or attempt to) the a.out and
older-gcc stuff in the earlier BSDs. In fact, obsd bears some
relationship to pre 2.8 FreeBSD in this regard, from a GNUstep
perspective.  

A fresh cut, probably from the base of NetBSD's current support in
GNUStep should be attempted.  Working from the current non-support for
OpenBSD in the makefiles is going to hurt, and be largely misleading.

Regards,
Christian.


> -----Original Message-----
> From: owner-ports@openbsd.org [mailto:owner-ports@openbsd.org] On
Behalf
> Of Jolan Luff
> Sent: Tuesday, May 06, 2003 7:49 AM
> To: ports@openbsd.org
> Subject: Re: Compiling GNUstep 1.6 under OpenBSD 3.2
> 
> On Tue, May 06, 2003 at 02:32:46AM +0100, Lane Myer wrote:
> > I did some searches of the newsgroups, and it seems some of the
problems
> are
> > related to ELF linking and shared libraries.
> >
> > Is there any chance running 3.3-current would work?
> 
> No, the same error happens with ELF/-current.