[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [SECURITY] php4 patches for 3.5 & 3.6



> Hi. I'd like to ask you to test the following patches.
> It takes php4 to version 4.3.11 in both branches.
> This is important, so please test it.
>
> Why?
> http://www.vuxml.org/openbsd/c6f452e8-b00a-11d9-825c-00065bd5b0b6.html
>
> The patches:
> http://cybersport.hu/~robert/patches/c6f452e8-b00a-11d9-825c-00065bd5b0b6_36.diff
http://cybersport.hu/~robert/patches/c6f452e8-b00a-11d9-825c-00065bd5b0b6_35.diff

Building on 3.6 i386:

...
===>  Extracting for php4-extensions-4.3.11
===>  Patching for php4-extensions-4.3.11
===>   Ignoring patchfile
/usr/ports/www/php4/patches/patch-aclocal_m4.orig
===>   Ignoring patchfile
/usr/ports/www/php4/patches/patch-configure_in.orig
No such line 1115 in input file, ignoring
  I can't seem to find a patch in there anywhere.
===>   Ignoring patchfile patch-ext_imap_config_m4.orig
Running autoconf-2.52 in
/usr/ports/www/php4/extensions/w-php-4.3.11-no_x11/php-4.3.11
configure.in:147: warning: AC_PROG_LEX invoked multiple times
...

It did build successfully on both i386 and amd64.  I can't actually
test the packages until I get home from work tonight, but I'll
report back then.

Thanks, Robert!

Benny


-- 
Nixon: "Hello, Morbo!  How's the family?"
Morbo: "Beligerant and numerous."
                                                  -- Futurama






Visit your host, monkey.org