[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
iplenable and ipfilter
- To: tech_(_at_)_openbsd_(_dot_)_org
- Subject: iplenable and ipfilter
- From: kwooding_(_at_)_codetalker_(_dot_)_com
- Date: Tue, 21 Dec 1999 23:41:57 -0700
- Cc: matthew_(_dot_)_patton_(_at_)_netsec_(_dot_)_net
I got looking at this one today while working in ipfilter.
Looking through the history of sys/netinet/ip_fil.c, at some point
we decided to change the name of the filter enable/disable functions
from iplattach() to ipl_enable() (and same for disable). From the code:
* Since iplattach() is called by main() at boot time, we put in a
* fake stub so that none of the machinery is initialized till explicitly
* enabled via ipf -E. Therefore we rename the real iplattach() to
* ipl_enable(). See also skeleton iplinit() later in this file.
I've faithfully preserved this modification in last three in-tree
versions, but, after taking a look, I don't think it is necessary. So
far as I can tell, we never call iplattach anywhere but within
Can anyone enlighten me here? Is this renaming actually necessary?
Visit your host, monkey.org